PHPCMS2008 typephp代码注入高危漏洞预警

发布时间:2019-08-13编辑:admin

  11月4日,阿里云安全首次捕获PHPCMS 2008版本的/type.php远程GetShell 0day利用攻击,攻击者可以利用该漏洞远程植入webshell,导致文件篡改、数据泄漏、服务器被远程控制等一系列严重问题。建议受影响用户尽快升级到最新版本修复。

  PHPCMS网站内容管理系统是国内主流CMS系统之一,同时也是一个开源的PHP开发框架。

  PHPCMS最早于2008年推出,最新版已出到v9.6.3,但由于稳定、灵活、开源的特性,时至今日,PHPCMS2008版本仍被许多网站所使用。

  PHPCMS网站内容管理系统是国内主流CMS系统之一,同时也是一个开源的PHP开发框架。

  PHPCMS最早于2008年推出,最新版已出到v9.6.3,但由于稳定、灵活、开源的特性,时至今日,PHPCMS2008版本仍被许多网站所使用。【招聘】年薪20万+光明区特聘岗位专干

  该漏洞源于PHPCMS2008源码中的/type.php文件。该文件包含如下代码:

  这里$template变量是用户能够通过传入参数控制的,同时可以看到该变量之后会被传入template()方法。而template()方法在/include/global.func.php文件中定义,包含如下代码:

  而前文所述的攻击payload将$template变量被设置为如下的值:

  虽然距离PHPCMS2008版本的推出已经10年,但仍有不少网站正在使用PHPCMS2008,包括政府、企业的网站;根据Fofa网络空间安全搜索引擎的全网精确搜索结果显示,还有近200个使用PHPCMS2008版本的网站;而如果使用模糊匹配对网站进行识别,匹配结果更达上万个。

  通过利用该漏洞,攻击者在向路径可控的文件写入恶意脚本代码后,后续将能够向该文件发送webshell指令,在服务器上执行任意代码,因此该代码注入漏洞的影响较大。

  临时解决可以在/type.php文件中对$template变量进行过滤,避免用户输入的含有”(“、”{“等符号的内容混入,并被当做路径和脚本内容处理。

  但由于PHPCMS2008版本过旧,用户应尽量升级到最新版本的PHPCMS,才能够更好地保障安全。

导航栏

Copyright © 2002-2011 DEDECMS. 织梦科技 版权所有 Power by DedeCms

现场报码| 香港马会挂牌正版彩图| 图库全年图纸记录| 香港正版资料免费大全| 香港挂牌网| 万众图库118心水论坛| 财神玄机资料玄机妙解| 香港内部精准免费资料| 牛魔王管家婆| 香港正版财神图库|